Prophix Dimensions/Cubes are Greyed out or "Cube is unprocessed or partially processed"
Summary of Issue:
When accessing a dimension in model manager you get the following error "cube is unprocessed or partially processed" causing the system to lock you out of any updates in model manager for that cube.
Error/Warning Messages:
1) "Member counts do not match. The dimension is either unprocessed or partially processed"

2). Cube in model manager appears to be italicized

Cause:
In cases where Model Manager is saving but is interrupted due to network issues, Prophix shutting down unexpectedly or a SQL conflict, you may encounter an error when trying to re-enter the dimension via Model Manager. The error will indicate that the cube is unprocessed or partially processed.
Resolution:
-Launch Prophix Process Manager
-Insert an Update Cube process
-Select the appropriate cube and set it to Process Full
-Run the process and verify that it completes successfully and then try entering the dimension again
If this does not rectify the issue or if you receive errors in the cube update process similar to the screenshot below, you can try processing the cube via the back end.

-Launch SSMS
-Connect to SSAS
-Expand Databases till you see the cubes
-Right click a cube and select Process
-If the selected cube shares dimensions with other cubes you can either process all the affected cubes OR process the whole database
-Ensure it is set to Process Full
-Select Change Settings and in the resulting window checkmark Process Affected Objects
-Select Dimension Key Errors tab in the same window
-Select Use Custom Error Configuration
-Change Processing Error Limit to Ignore Errors Count
-Set the specific error conditions to Ignore Error
-Click OK and then OK again to start processing
-Repeat for any other cubes as needed or where dimensions may be shared
-Once complete, try reprocessing via Prophix to ensure there are no further errors


