You cannot start application PROPHIX for SQL Server from this location because it is already installed from a different location
Summary of Symptoms:
When a user clicks on a workflow url link via a workflow email they receive and error and the workflow task does not open.
Error/Warning Messages:
"You cannot start application PROPHIX for SQL Server from this location because it is already installed from a different location".

Cause:
The above issue stems from the ClickOnce deployment utilized for the smart client application. Any updates to the application must occur from the same location. For example the following URLs point to the same physical server:
- http://PDM/smartclient
- http://PDM.prophix.com/smartclient
- http://192.255.255.140/smartclient
however if you deploy the client from http://PDM/smartclient and then attempt to deploy from the other two references you would receive the reported error.
Workaround/Resolution:
As the smartclient deployment is done for users on their client machines the steps outlined below will allow users to access Prophix via their desktop icon and/or workflow link:
For users that haven't deployed the smartclient please deploy through IE and enter the following within the URL:
http://Servername:80/smartclient/prophix%20for%20sql%20server.application? (replace servername with the Prophix server)

This should prompt to install the smartclient and add a desktop icon once logged in successfully.
For users that have already deployed the smartclient please do the following:
1. Launch Control Panel and uninstall PROPHIX for SQL Server
2. From Windows Explorer browse to:
C:\Users\username\AppData\Local\Apps\ and delete the 2.0 folder
C:\Users\username\AppData\Local\ and delete the Prophix folder
C:\Users\username\AppData\Roaming\ and delete the Prophix folder
3. Launch IE and enter the following URL: http://Servername:80/smartclient/prophix%20for%20sql%20server.application?
***NOTE*** Prophix only launches properly in Internet Explorer. If the users default browser is set to something other than IE and you attempt to launch Prophix from the desktop shortcut it will not work. Work around is to take the target for the Prophix shortcut and create a favorite in IE with it.
This should prompt to install the smartclient and add the desktop icon. Once completed attempt to launch the URL embedded within the workflow task email to confirm that users can open the task without the error message. In addition to this, have users connect from their desktop icon to ensure this can connect.